Difference between revisions of "Drift/Pakkeinstallasjon"

From Programvareverkstedet
Jump to navigation Jump to search
(username removed)
 
Line 2: Line 2:
  
 
== Debian / Ubuntu ==
 
== Debian / Ubuntu ==
Oppdater pakkeliste: <pre><nowiki>
 
aptitude update
 
</nowiki></pre>
 
 
Søk etter pakker: <pre><nowiki>
 
Søk etter pakker: <pre><nowiki>
 
aptitude search <tekst>
 
aptitude search <tekst>
</nowiki></pre>
 
Vis info om pakke: <pre><nowiki>
 
aptitude show <pakke>
 
 
</nowiki></pre>
 
</nowiki></pre>
 
Installer pakker: <pre><nowiki>
 
Installer pakker: <pre><nowiki>
Line 16: Line 10:
  
 
== Gentoo ==
 
== Gentoo ==
Søk etter pakker: <pre><nowiki>
 
emerge --search <søkestreng>
 
</nowiki></pre>
 
 
Vis hva som vil installeres: <pre><nowiki>
 
emerge -pv <pakke>
 
</nowiki></pre>
 
 
 
Installer pakker: <pre><nowiki>
 
Installer pakker: <pre><nowiki>
 
emerge <pakke>
 
emerge <pakke>
Line 29: Line 15:
  
 
== [[DragonFly]] ==
 
== [[DragonFly]] ==
Installer pakker: <pre><nowiki>
+
vet ikke :-(
pkg_add ftp://ftp.pvv.ntnu.no/pub/DragonFly/packages/pkgsrc-current/DragonFly/1.4.0-RELEASE/i386/All/<pakke>
 
</nowiki></pre>
 
  
 
== FreeBSD ==
 
== FreeBSD ==
Installer pakker: <pre><nowiki>
+
vet ikke :-(
pkg_add -r <pakkenavn>
 
</nowiki></pre>
 
  
 
== NetBSD ==
 
== NetBSD ==
vet ikke <<Verbatim(:-()>>
+
vet ikke :-(
 
 
== Solaris 10 ==
 
Søk etter pakker: http://www.sunfreeware.com/
 
 
 
Installer pakker: <pre><nowiki>
 
cd /root
 
/usr/sfw/bin/wget ftp://ftp.sunfreeware.com/pub/freeware/sparc/10/rcs-5.7-sol10-sparc-local.gz
 
gunzip rcs-5.7-sol10-sparc-local.gz
 
pkgadd -d rcs-5.7-sol10-sparc-local
 
</nowiki></pre>
 
 
 
Om pkgadd -d feiler pga for liten /var: <pre><nowiki>
 
mkdir /tmp/spool
 
pkgadd -s /tmp/spool -d rcs-5.7-sol10-sparc-local
 
cd /tmp/spool
 
pkgadd -d .
 
cd
 
rm -r /tmp/spool
 
</nowiki></pre>
 
  
 
__NOTOC__
 
__NOTOC__

Revision as of 18:09, 8 February 2006

Installasjon av programvare på de ulike OS-ene vi drifter.

Debian / Ubuntu

Søk etter pakker:

aptitude search <tekst>

Installer pakker:

aptitude install <pakke>

Gentoo

Installer pakker:

emerge <pakke>

DragonFly

vet ikke :-(

FreeBSD

vet ikke :-(

NetBSD

vet ikke :-(